<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
<title>DIXIE D&#8217;AMELIO EXPLAINED HOW SHE FELT WHEN NOAH BECK WENT PUBLIC WITH THEIR RELATIONSHIP | D1SoftballNews.com</title>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="pingback" href="http://www.d1softballnews.com/xmlrpc.php" />
<link rel="icon" type="image/png" href="http://www.d1softballnews.com/wp-content/uploads/2020/10/d1-favi.png"><link rel="amphtml" href="http://www.d1softballnews.com/dixie-damelio-explained-how-she-felt-when-noah-beck-went-public-with-their-relationship/amp/" /><meta name="generator" content="AMP for WP 1.0.68.1" /><link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="D1SoftballNews.com &raquo; Feed" href="http://www.d1softballnews.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="D1SoftballNews.com &raquo; Comments Feed" href="http://www.d1softballnews.com/comments/feed/" />

<script type="text/javascript" data-cfasync="false">
    (window.gaDevIds=window.gaDevIds||[]).push("dNDMyYj");
	var em_version         = '6.3.0';
	var em_track_user      = true;
	var em_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-131292421-2';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}

	if ( 'undefined' === typeof gaOptout ) {
		function gaOptout() {
			__gaTrackerOptout();
		}
	}
	
	if ( em_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

window.ga = __gaTracker;		__gaTracker('create', 'UA-131292421-2', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('send','pageview');
		__gaTracker( function() { window.ga = __gaTracker; } );
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + em_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
			window.ga = __gaTracker;		})();
		}
</script>

<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.d1softballnews.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.5.3"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='http://www.d1softballnews.com/wp-includes/css/dist/block-library/style.min.css?ver=5.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='quads-style-css-css' href='http://www.d1softballnews.com/wp-content/plugins/quick-adsense-reloaded/includes/gutenberg/dist/blocks.style.build.css?ver=2.0.16' type='text/css' media='all' />
<link rel='stylesheet' id='mpp_gutenberg-css' href='http://www.d1softballnews.com/wp-content/plugins/metronet-profile-picture/dist/blocks.style.build.css?ver=2.3.11' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css' href='http://www.d1softballnews.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.3' type='text/css' media='all' />
<link rel='stylesheet' id='wp_automatic_gallery_style-css' href='http://www.d1softballnews.com/wp-content/plugins/wp-automatic/css/wp-automatic.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='exactmetrics-popular-posts-style-css' href='http://www.d1softballnews.com/wp-content/plugins/google-analytics-dashboard-for-wp/assets/css/frontend.min.css?ver=6.3.0' type='text/css' media='all' />
<link rel='stylesheet' id='td-plugin-multi-purpose-css' href='http://www.d1softballnews.com/wp-content/plugins/td-composer/td-multi-purpose/style.css?ver=a658a28d2ec596dae36323688c6c3eb8' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css' href="https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C600%2C700%7CRoboto%3A400%2C500%2C700&#038;display=swap&#038;ver=10.3.7" type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css' href='http://www.d1softballnews.com/wp-content/themes/Newspaper/style.css?ver=10.3.7' type='text/css' media='all' />
<style id='td-theme-inline-css' type='text/css'>
    
        @media (max-width: 767px) {
            .td-header-desktop-wrap {
                display: none;
            }
        }
        @media (min-width: 767px) {
            .td-header-mobile-wrap {
                display: none;
            }
        }
    
	
</style>
<link rel='stylesheet' id='td-legacy-framework-front-style-css' href='http://www.d1softballnews.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/css/td_legacy_main.css?ver=a658a28d2ec596dae36323688c6c3eb8' type='text/css' media='all' />
<link rel='stylesheet' id='td-standard-pack-framework-front-style-css' href='http://www.d1softballnews.com/wp-content/plugins/td-standard-pack/Newspaper/assets/css/td_standard_pack_main.css?ver=403b2dc7f9eb8aa26884edcb2afa1fce' type='text/css' media='all' />
<link rel='stylesheet' id='tdb_front_style-css' href='http://www.d1softballnews.com/wp-content/plugins/td-cloud-library/assets/css/tdb_less_front.css?ver=53f7b7675c3127e69efacf5620821cc8' type='text/css' media='all, print' />
<style id='quads-styles-inline-css' type='text/css'>
.quads-ad-label { font-size: 12px; text-align: center; color: #333;}
</style>
<script type='text/javascript' id='exactmetrics-frontend-script-js-extra'>
/* <![CDATA[ */
var exactmetrics_frontend = {"js_events_tracking":"true","download_extensions":"zip,mp3,mpeg,pdf,docx,pptx,xlsx,rar","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"http:\/\/www.d1softballnews.com","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.d1softballnews.com/wp-content/plugins/google-analytics-dashboard-for-wp/assets/js/frontend.min.js?ver=6.3.0' id='exactmetrics-frontend-script-js'></script>
<script type='text/javascript' src='http://www.d1softballnews.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp' id='jquery-core-js'></script>
<script type='text/javascript' src='http://www.d1softballnews.com/wp-content/plugins/wp-automatic/js/main-front.js?ver=5.5.3' id='wp_automatic_gallery-js'></script>
<link rel="https://api.w.org/" href="http://www.d1softballnews.com/wp-json/" /><link rel="alternate" type="application/json" href="http://www.d1softballnews.com/wp-json/wp/v2/posts/85663" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.d1softballnews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.d1softballnews.com/wp-includes/wlwmanifest.xml" />
<link rel='prev' title='DUA LIPA: THE BEHIND THE SCENES VIDEO FOR “LEVITATING” FT. IS OUT. DABABY' href='http://www.d1softballnews.com/dua-lipa-the-behind-the-scenes-video-for-levitating-ft-is-out-dababy/' />
<link rel='next' title='BTS: WATCH THE FIRST TEASER OF THE &#8220;LIFE GOES ON&#8221; VIDEO DIRECTED BY JUNGKOOK' href='http://www.d1softballnews.com/bts-watch-the-first-teaser-of-the-life-goes-on-video-directed-by-jungkook/' />
<meta name="generator" content="WordPress 5.5.3" />
<link rel='shortlink' href='http://www.d1softballnews.com/?p=85663' />
<link rel="alternate" type="application/json+oembed" href="http://www.d1softballnews.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.d1softballnews.com%2Fdixie-damelio-explained-how-she-felt-when-noah-beck-went-public-with-their-relationship%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.d1softballnews.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.d1softballnews.com%2Fdixie-damelio-explained-how-she-felt-when-noah-beck-went-public-with-their-relationship%2F&#038;format=xml" />
<link rel="preconnect" href="https://cdnjs.cloudflare.com"><meta property="og:image" content="http://www.d1softballnews.com/wp-content/uploads/2020/11/dixie-1.jpg" /><meta property="og:title" content='DIXIE D&#8217;AMELIO EXPLAINED HOW SHE FELT WHEN NOAH BECK WENT PUBLIC WITH THEIR RELATIONSHIP' />
<meta property="og:description" content='' />
<meta name="twitter:card" content='summary_large_image' />
<meta name="twitter:title" content='DIXIE D&#8217;AMELIO EXPLAINED HOW SHE FELT WHEN NOAH BECK WENT PUBLIC WITH THEIR RELATIONSHIP' />
<meta name="twitter:description" content='' /><meta name="twitter:image" content="http://www.d1softballnews.com/wp-content/uploads/2020/11/dixie-1.jpg" /><script type="text/javascript" src="http://www.d1softballnews.com/wp-content/plugins/quick-adsense-reloaded/assets/js/ads.js"></script><script type='text/javascript'>document.cookie = 'quads_browser_width='+screen.width;</script><!--[if lt IE 9]><script src="http://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
<script>
        window.tdb_globals = {"wpRestNonce":"762c9015cb","wpRestUrl":"http:\/\/www.d1softballnews.com\/wp-json\/","permalinkStructure":"\/%postname%\/","isAjax":false,"isAdminBarShowing":false,"autoloadScrollPercent":50,"postAutoloadStatus":"off","origPostEditUrl":null};
    </script>
<script>
				window.tdwGlobal = {"adminUrl":"http:\/\/www.d1softballnews.com\/wp-admin\/","wpRestNonce":"762c9015cb","wpRestUrl":"http:\/\/www.d1softballnews.com\/wp-json\/","permalinkStructure":"\/%postname%\/"};
			</script>

<script>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</script>
<meta name="google-site-verification" content="bfWJpJJphYtX5e0S-NYPzi5ap0rPres77Ub7p4cd5Y4" />
<script data-ad-client="ca-pub-5677985950896607" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "http://www.d1softballnews.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "http://www.d1softballnews.com/category/celebrities/",
                    "name": "CELEBRITIES"
                }
            }
            ,{
                "@type": "ListItem",
                "position": 3,
                    "item": {
                    "@type": "WebPage",
                    "@id": "http://www.d1softballnews.com/dixie-damelio-explained-how-she-felt-when-noah-beck-went-public-with-their-relationship/",
                    "name": "DIXIE D&#8217;AMELIO EXPLAINED HOW SHE FELT WHEN NOAH BECK WENT PUBLIC WITH..."                                
                }
            }    
        ]
    }
</script>

<style>
    
</style>
<style id="tdw-css-placeholder"></style></head>
<body class="post-template-default single single-post postid-85663 single-format-standard td-standard-pack dixie-damelio-explained-how-she-felt-when-noah-beck-went-public-with-their-relationship global-block-template-1 td-animation-stack-type0 td-full-layout" itemscope="itemscope" itemtype="http://schema.org/WebPage">
<div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
<div class="td-menu-background"></div>
<div id="td-mobile-nav">
<div class="td-mobile-container">

<div class="td-menu-socials-wrap">

<div class="td-menu-socials">
</div>

<div class="td-mobile-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
</div>


<div class="td-mobile-content">
<div class="menu-header-menu-container"><ul id="menu-header-menu" class="td-mobile-main-menu"><li id="menu-item-17" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first menu-item-17"><a href="http://www.d1softballnews.com/category/news/" data-wpel-link="internal">NEWS</a></li>
<li id="menu-item-16" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16"><a href="http://www.d1softballnews.com/category/gaming/" data-wpel-link="internal">GAMING</a></li>
<li id="menu-item-19" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19"><a href="http://www.d1softballnews.com/category/technology/" data-wpel-link="internal">TECH</a></li>
<li id="menu-item-15" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15"><a href="http://www.d1softballnews.com/category/entertainment/" data-wpel-link="internal">ENTERTAINMENT</a></li>
<li id="menu-item-12656" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-12656"><a href="http://www.d1softballnews.com/category/celebrities/" data-wpel-link="internal">CELEBRITIES</a></li>
</ul></div> </div>
</div>

<div id="login-form-mobile" class="td-register-section">
<div id="td-login-mob" class="td-login-animation td-login-hide-mob">

<div class="td-login-close">
<a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
<div class="td-login-title">Sign in</div>

<div class="td-mobile-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
</div>
<div class="td-login-form-wrap">
<div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div>
<div class="td_display_err"></div>
<div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div>
<div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div>
<input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN">
<div class="td-login-info-text">
<a href="#" id="forgot-pass-link-mob">Forgot your password?</a>
</div>
<div class="td-login-register-link">
</div>
<div class="td-login-info-text"><a class="privacy-policy-link" href="http://www.d1softballnews.com/privacy-policy/" data-wpel-link="internal">Privacy Policy</a></div>
</div>
</div>
<div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob">

<div class="td-forgot-pass-close">
<a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
<div class="td-login-title">Password recovery</div>
</div>
<div class="td-login-form-wrap">
<div class="td-login-panel-title">Recover your password</div>
<div class="td_display_err"></div>
<div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div>
<input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass">
</div>
</div>
</div>
</div> <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
<div class="td-drop-down-search">
<form method="get" class="td-search-form" action="http://www.d1softballnews.com/">

<div class="td-search-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
<div role="search" class="td-search-input">
<span>Search</span>
<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
</div>
</form>
<div id="td-aj-search-mob" class="td-ajax-search-flex"></div>
</div>
</div>
<div id="td-outer-wrap" class="td-theme-wrap">
<div class="tdc-header-wrap ">

<div class="td-header-wrap td-header-style-5 ">
<div class="td-header-top-menu-full td-container-wrap ">
<div class="td-container td-header-row td-header-top-menu">
<div class="top-bar-style-1">
<div class="td-header-sp-top-menu">
</div>
<div class="td-header-sp-top-widget">
</div> </div>

<div id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
<div class="td-login-wrap">
<a href="#" class="td-back-button"><i class="td-icon-modal-back"></i></a>
<div id="td-login-div" class="td-login-form-div td-display-block">
<div class="td-login-panel-title">Sign in</div>
<div class="td-login-panel-descr">Welcome! Log into your account</div>
<div class="td_display_err"></div>
<div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email" value="" required><label>your username</label></div>
<div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" required><label>your password</label></div>
<input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login">
<div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password? Get help</a></div>
<div class="td-login-info-text"><a class="privacy-policy-link" href="http://www.d1softballnews.com/privacy-policy/" data-wpel-link="internal">Privacy Policy</a></div>
</div>
<div id="td-forgot-pass-div" class="td-login-form-div td-display-none">
<div class="td-login-panel-title">Password recovery</div>
<div class="td-login-panel-descr">Recover your password</div>
<div class="td_display_err"></div>
<div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label>your email</label></div>
<input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password">
<div class="td-login-info-text">A password will be e-mailed to you.</div>
</div>
</div>
</div>
</div>
</div>
<div class="td-header-menu-wrap-full td-container-wrap ">
<div class="td-header-menu-wrap ">
<div class="td-container td-header-row td-header-main-menu black-menu">
<div id="td-header-menu" role="navigation">
<div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
<div class="td-main-menu-logo td-logo-in-menu">
<a class="td-main-logo" href="http://www.d1softballnews.com/" data-wpel-link="internal">
<img src="http://www.d1softballnews.com/wp-content/uploads/2020/10/d1softball-logo.png" alt="" />
<span class="td-visual-hidden">D1SoftballNews.com</span>
</a>
</div>
<div class="menu-header-menu-container"><ul id="menu-header-menu-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-normal-menu menu-item-17"><a href="http://www.d1softballnews.com/category/news/" data-wpel-link="internal">NEWS</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-16"><a href="http://www.d1softballnews.com/category/gaming/" data-wpel-link="internal">GAMING</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-19"><a href="http://www.d1softballnews.com/category/technology/" data-wpel-link="internal">TECH</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-15"><a href="http://www.d1softballnews.com/category/entertainment/" data-wpel-link="internal">ENTERTAINMENT</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-12656"><a href="http://www.d1softballnews.com/category/celebrities/" data-wpel-link="internal">CELEBRITIES</a></li>
</ul></div></div>
<div class="header-search-wrap">
<div class="td-search-btns-wrap">
<a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
<a id="td-header-search-button-mob" href="#" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
</div>
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="http://www.d1softballnews.com/">
<div role="search" class="td-head-form-search-wrap">
<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
</div>
</form>
<div id="td-aj-search"></div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="td-main-content-wrap td-container-wrap">
<div class="td-container td-post-template-default ">
<div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="http://www.d1softballnews.com/" data-wpel-link="internal">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in CELEBRITIES" class="entry-crumb" href="http://www.d1softballnews.com/category/celebrities/" data-wpel-link="internal">CELEBRITIES</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">DIXIE D&#8217;AMELIO EXPLAINED HOW SHE FELT WHEN NOAH BECK WENT PUBLIC WITH...</span></div></div>
<div class="td-pb-row">
<div class="td-pb-span8 td-main-content" role="main">
<div class="td-ss-main-content">
<article id="post-85663" class="post-85663 post type-post status-publish format-standard has-post-thumbnail category-celebrities tag-dixie-damelio" itemscope itemtype="http://schema.org/Article" 46>
<div class="td-post-header">
<ul class="td-category"><li class="entry-category"><a href="http://www.d1softballnews.com/category/celebrities/" data-wpel-link="internal">CELEBRITIES</a></li></ul>
<header class="td-post-title">
<h1 class="entry-title">DIXIE D&#8217;AMELIO EXPLAINED HOW SHE FELT WHEN NOAH BECK WENT PUBLIC WITH THEIR RELATIONSHIP</h1>
<div class="td-module-meta-info">
<div class="td-post-author-name"><div class="td-author-by">By</div> <a href="http://www.d1softballnews.com/author/d1-soft/" data-wpel-link="internal">D1 Soft Ball News</a><div class="td-author-line"> - </div> </div> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-11-18T05:20:09+00:00">November 18, 2020</time></span> <div class="td-post-comments"><a href="http://www.d1softballnews.com/dixie-damelio-explained-how-she-felt-when-noah-beck-went-public-with-their-relationship/#respond" data-wpel-link="internal"><i class="td-icon-comments"></i>0</a></div> <div class="td-post-views"><i class="td-icon-views"></i><span class="td-nr-views-85663">49</span></div> </div>
</header>
</div>
<div class="td-post-sharing-top"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-bg td-ps-padding td-post-sharing-style2 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=http%3A%2F%2Fwww.d1softballnews.com%2Fdixie-damelio-explained-how-she-felt-when-noah-beck-went-public-with-their-relationship%2F" data-wpel-link="external" target="_blank" rel="external noopener noreferrer">
<div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
<div class="td-social-but-text">Facebook</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=DIXIE+D%E2%80%99AMELIO+EXPLAINED+HOW+SHE+FELT+WHEN+NOAH+BECK+WENT+PUBLIC+WITH+THEIR+RELATIONSHIP&amp;url=http%3A%2F%2Fwww.d1softballnews.com%2Fdixie-damelio-explained-how-she-felt-when-noah-beck-went-public-with-their-relationship%2F&amp;via=D1SoftballNews.com" data-wpel-link="external" target="_blank" rel="external noopener noreferrer">
<div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
<div class="td-social-but-text">Twitter</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="https://api.whatsapp.com/send?text=DIXIE+D%E2%80%99AMELIO+EXPLAINED+HOW+SHE+FELT+WHEN+NOAH+BECK+WENT+PUBLIC+WITH+THEIR+RELATIONSHIP %0A%0A http://www.d1softballnews.com/dixie-damelio-explained-how-she-felt-when-noah-beck-went-public-with-their-relationship/" data-wpel-link="external" target="_blank" rel="external noopener noreferrer">
<div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
<div class="td-social-but-text">WhatsApp</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-reddit" href="https://reddit.com/submit?url=http://www.d1softballnews.com/dixie-damelio-explained-how-she-felt-when-noah-beck-went-public-with-their-relationship/&amp;title=DIXIE+D%E2%80%99AMELIO+EXPLAINED+HOW+SHE+FELT+WHEN+NOAH+BECK+WENT+PUBLIC+WITH+THEIR+RELATIONSHIP" data-wpel-link="external" target="_blank" rel="external noopener noreferrer">
<div class="td-social-but-icon"><i class="td-icon-reddit"></i></div>
<div class="td-social-but-text">ReddIt</div>
</a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top">
<div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
</a></div></div></div>
<div class="td-post-content tagdiv-type">
<div class="td-post-featured-image"><a href="http://www.d1softballnews.com/wp-content/uploads/2020/11/dixie-1.jpg" data-caption="" data-wpel-link="internal"><img width="696" height="391" class="entry-thumb td-modal-image" src="http://www.d1softballnews.com/wp-content/uploads/2020/11/dixie-1-696x391.jpg" srcset="http://www.d1softballnews.com/wp-content/uploads/2020/11/dixie-1-696x391.jpg 696w, http://www.d1softballnews.com/wp-content/uploads/2020/11/dixie-1-300x169.jpg 300w, http://www.d1softballnews.com/wp-content/uploads/2020/11/dixie-1-1024x575.jpg 1024w, http://www.d1softballnews.com/wp-content/uploads/2020/11/dixie-1-768x431.jpg 768w, http://www.d1softballnews.com/wp-content/uploads/2020/11/dixie-1-1068x600.jpg 1068w, http://www.d1softballnews.com/wp-content/uploads/2020/11/dixie-1-748x420.jpg 748w, http://www.d1softballnews.com/wp-content/uploads/2020/11/dixie-1.jpg 1280w" sizes="(max-width: 696px) 100vw, 696px" alt="" title="dixie" /></a></div>


<div class="quads-location quads-ad1" id="quads-ad1" style="float:none;margin:0px;">

<div id="M509325ScriptRootC990890">
</div>
<script src="https://jsc.mgid.com/d/1/d1softballnews.com.990890.js" async></script>

</div>
<p>At the beginning of last October, <strong>Noah Beck</strong> had <strong>confirmed the romance</strong> with <strong>Dixie D&#8217;Amelio</strong> during an interview.</p>
<p>Now the TikTok has revealed that <strong>she had no idea that her boyfriend would go public with their relationship</strong> and told how he reacted.</p>
<p>&#8221; <strong><em>I was happy and angry at the same time,</em></strong> &#8221; confessed in her podcast <em>2 Chix.</em></p>
<p>&#8221; <em>I was angry that I didn&#8217;t participate in the decision, because <strong>I like to be in control and make my own decisions</strong>. But it was also nice because <strong>I know how much he cares about me. It was good and I&#8217;m happy about it</strong>. public</em> &#8220;.</p>
<p>Dixie D&#8217;Amelio feared <strong>external influence on the love story</strong> before it was public: &#8221; <em><strong>It can mess up a relationship</strong>. I&#8217;ve already been in a commented relationship on the Internet and <strong>the fact that it&#8217;s there for all to see makes it much more difficult</strong></em> .&#8221; The reference is to the <strong>former Griffin Johnson</strong>.</p>
<p>Particularly the online comments, which she admitted reading already at the time when it was only rumored that she and Noah Beck were a couple: &#8221; <em>There were those who wrote that I didn&#8217;t give them enough attention and I thought: &#8216;I&#8217;m not ready to show what did I feel</em> &#8220;.</p>
<blockquote class="instagram-media" style="background: #FFF; border: 0; border-radius: 3px; box-shadow: 0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width: 540px; min-width: 326px; padding: 0; width: calc(100% - 2px);" data-instgrm-captioned="" data-instgrm-permalink="https://www.instagram.com/p/CHqyetYDzLy/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="13">
<div style="padding: 16px;">
<p>&nbsp;</p>
<div style="display: flex; flex-direction: row; align-items: center;">
<div style="background-color: #f4f4f4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div>
<div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;">
<div style="background-color: #f4f4f4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div>
<div style="background-color: #f4f4f4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div>
</div>
</div>
<div style="padding: 19% 0;"></div>
<div style="display: block; height: 50px; margin: 0 auto 12px; width: 50px;"></div>
<div style="padding-top: 8px;">
<div style="color: #3897f0; font-family: Arial,sans-serif; font-size: 14px; font-style: normal; font-weight: 550; line-height: 18px;">View this post on Instagram</div>
</div>
<div style="padding: 12.5% 0;"></div>
<div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;">
<div>
<div style="background-color: #f4f4f4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div>
<div style="background-color: #f4f4f4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div>
<div style="background-color: #f4f4f4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div>
</div>
<div style="margin-left: 8px;">
<div style="background-color: #f4f4f4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div>
<div style="width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg);"></div>
</div>
<div style="margin-left: auto;">
<div style="width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div>
<div style="background-color: #f4f4f4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div>
<div style="width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div>
</div>
</div>
<div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center; margin-bottom: 24px;">
<div style="background-color: #f4f4f4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 224px;"></div>
<div style="background-color: #f4f4f4; border-radius: 4px; flex-grow: 0; height: 14px; width: 144px;"></div>
</div>
<p>&nbsp;</p>
<p style="color: #c9c8cd; font-family: Arial,sans-serif; font-size: 14px; line-height: 17px; margin-bottom: 0; margin-top: 8px; overflow: hidden; padding: 8px 0 7px; text-align: center; text-overflow: ellipsis; white-space: nowrap;"><a style="color: #c9c8cd; font-family: Arial,sans-serif; font-size: 14px; font-style: normal; font-weight: normal; line-height: 17px; text-decoration: none;" href="https://www.instagram.com/p/CHqyetYDzLy/?utm_source=ig_embed&amp;utm_campaign=loading" target="_blank" rel="noopener noreferrer external" data-wpel-link="external">A post shared by dixie damelio (@dixiedamelio)</a></p>
</div>
</blockquote>
<p><script async src="//www.instagram.com/embed.js"></script></p>
<p class="body-text">Speaking of experiencing the relationship in public, <strong>Dixie D&#8217;Amelio recently responded to haters</strong> who claimed that she and her boyfriend would do anything to get attention.</p>

<div class="quads-location quads-ad3" id="quads-ad3" style="float:none;margin:0px;">

<div id="M509325ScriptRootC990890">
</div>
<script src="https://jsc.mgid.com/d/1/d1softballnews.com.990890.js" async></script>

</div>
<div class="td-a-rec td-a-rec-id-content_bottom  tdi_1_759 td_block_template_1">
<style>
/* custom css */
.tdi_1_759.td-a-rec{
					text-align: center;
				}.tdi_1_759 .td-element-style{
					z-index: -1;
				}.tdi_1_759.td-a-rec-img{
				    text-align: left;
				}.tdi_1_759.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_1_759.td-a-rec-img {
				        text-align: center;
				    }
                }
</style>
<div id="M509325ScriptRootC1027202">
</div>
<script src="https://jsc.mgid.com/d/1/d1softballnews.com.1027202.js" async></script>
</div> </div>
<footer>
 
<div class="td-post-source-tags">
 <ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="http://www.d1softballnews.com/tag/dixie-damelio/" data-wpel-link="internal">Dixie D'Amelio</a></li></ul> </div>
<div class="td-post-sharing-bottom"><div class="td-post-sharing-classic"><iframe frameBorder="0" src="https://www.facebook.com/plugins/like.php?href=http://www.d1softballnews.com/dixie-damelio-explained-how-she-felt-when-noah-beck-went-public-with-their-relationship/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:auto; height:21px; background-color:transparent;"></iframe></div><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-padding td-ps-rounded td-post-sharing-style4 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=http%3A%2F%2Fwww.d1softballnews.com%2Fdixie-damelio-explained-how-she-felt-when-noah-beck-went-public-with-their-relationship%2F" data-wpel-link="external" target="_blank" rel="external noopener noreferrer">
<div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
<div class="td-social-but-text">Facebook</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=DIXIE+D%E2%80%99AMELIO+EXPLAINED+HOW+SHE+FELT+WHEN+NOAH+BECK+WENT+PUBLIC+WITH+THEIR+RELATIONSHIP&amp;url=http%3A%2F%2Fwww.d1softballnews.com%2Fdixie-damelio-explained-how-she-felt-when-noah-beck-went-public-with-their-relationship%2F&amp;via=D1SoftballNews.com" data-wpel-link="external" target="_blank" rel="external noopener noreferrer">
<div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
<div class="td-social-but-text">Twitter</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="https://api.whatsapp.com/send?text=DIXIE+D%E2%80%99AMELIO+EXPLAINED+HOW+SHE+FELT+WHEN+NOAH+BECK+WENT+PUBLIC+WITH+THEIR+RELATIONSHIP %0A%0A http://www.d1softballnews.com/dixie-damelio-explained-how-she-felt-when-noah-beck-went-public-with-their-relationship/" data-wpel-link="external" target="_blank" rel="external noopener noreferrer">
<div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
<div class="td-social-but-text">WhatsApp</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-reddit" href="https://reddit.com/submit?url=http://www.d1softballnews.com/dixie-damelio-explained-how-she-felt-when-noah-beck-went-public-with-their-relationship/&amp;title=DIXIE+D%E2%80%99AMELIO+EXPLAINED+HOW+SHE+FELT+WHEN+NOAH+BECK+WENT+PUBLIC+WITH+THEIR+RELATIONSHIP" data-wpel-link="external" target="_blank" rel="external noopener noreferrer">
<div class="td-social-but-icon"><i class="td-icon-reddit"></i></div>
<div class="td-social-but-text">ReddIt</div>
</a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom">
<div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
</a></div></div></div> <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="http://www.d1softballnews.com/dua-lipa-the-behind-the-scenes-video-for-levitating-ft-is-out-dababy/" data-wpel-link="internal">DUA LIPA: THE BEHIND THE SCENES VIDEO FOR “LEVITATING” FT. IS OUT. DABABY</a></div></div><div class="td-next-prev-separator"></div><div class="td-block-span6 td-post-next-post"><div class="td-post-next-prev-content"><span>Next article</span><a href="http://www.d1softballnews.com/bts-watch-the-first-teaser-of-the-life-goes-on-video-directed-by-jungkook/" data-wpel-link="internal">BTS: WATCH THE FIRST TEASER OF THE &#8220;LIFE GOES ON&#8221; VIDEO DIRECTED BY JUNGKOOK</a></div></div></div> <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="http://www.d1softballnews.com/author/d1-soft/" data-wpel-link="internal">D1 Soft Ball News</a></span></div> <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="D1 Soft Ball News"></span><meta itemprop="datePublished" content="2020-11-18T05:20:09+00:00"><meta itemprop="dateModified" content="2020-11-18T05:20:09+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="http://www.d1softballnews.com/dixie-damelio-explained-how-she-felt-when-noah-beck-went-public-with-their-relationship/" /><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://www.d1softballnews.com/wp-content/uploads/2020/10/d1softball-logo.png"></span><meta itemprop="name" content="D1SoftballNews.com"></span><meta itemprop="headline " content="DIXIE D&#039;AMELIO EXPLAINED HOW SHE FELT WHEN NOAH BECK WENT PUBLIC WITH THEIR RELATIONSHIP"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://www.d1softballnews.com/wp-content/uploads/2020/11/dixie-1.jpg"><meta itemprop="width" content="1280"><meta itemprop="height" content="719"></span> </footer>
</article> 
<div class="td_block_wrap td_block_related_posts tdi_2_c9b td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="tdi_2_c9b"><script>var block_tdi_2_c9b = new tdBlock();
block_tdi_2_c9b.id = "tdi_2_c9b";
block_tdi_2_c9b.atts = '{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"tdi_2_c9b","td_column_number":3,"block_type":"td_block_related_posts","live_filter_cur_post_id":85663,"live_filter_cur_post_author":"6","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"tdi_2_c9b","tdc_css_class_style":"tdi_2_c9b_rand_style"}';
block_tdi_2_c9b.td_column_number = "3";
block_tdi_2_c9b.block_type = "td_block_related_posts";
block_tdi_2_c9b.post_count = "3";
block_tdi_2_c9b.found_posts = "16244";
block_tdi_2_c9b.header_color = "";
block_tdi_2_c9b.ajax_pagination_infinite_stop = "";
block_tdi_2_c9b.max_num_pages = "5415";
tdBlocksArray.push(block_tdi_2_c9b);
</script><h4 class="td-related-title td-block-title"><a id="tdi_3_444" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="tdi_2_c9b" href="#">RELATED ARTICLES</a><a id="tdi_4_0db" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="tdi_2_c9b" href="#">MORE FROM AUTHOR</a></h4><div id=tdi_2_c9b class="td_block_inner">
<div class="td-related-row">
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.d1softballnews.com/kim-kardashian-posted-an-unpublished-video-of-the-best-moments-of-her-40-years-birthday-blog/" rel="bookmark" class="td-image-wrap " title="Kim Kardashian posted an unpublished video of the best moments of her 40 years: &#8220;Birthday blog&#8221;"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Kim Kardashian posted an unpublished video of the best moments of her 40 years: &#8220;Birthday blog&#8221;" data-type="image_tag" data-img-url="http://www.d1softballnews.com/wp-content/uploads/2020/11/kim-kardashian-218x150.jpg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.d1softballnews.com/kim-kardashian-posted-an-unpublished-video-of-the-best-moments-of-her-40-years-birthday-blog/" rel="bookmark" title="Kim Kardashian posted an unpublished video of the best moments of her 40 years: &#8220;Birthday blog&#8221;" data-wpel-link="internal">Kim Kardashian posted an unpublished video of the best moments of her 40 years: &#8220;Birthday blog&#8221;</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.d1softballnews.com/j-los-skincare-line-is-coming-and-no-one-will-age-quite-like-her/" rel="bookmark" class="td-image-wrap " title="JENNIFER LOPEZ&#8217;S SKINCARE LINE IS COMING &#8211; AND NO ONE WILL AGE QUITE LIKE HER"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="JENNIFER LOPEZ&#8217;S SKINCARE LINE IS COMING &#8211; AND NO ONE WILL AGE QUITE LIKE HER" data-type="image_tag" data-img-url="http://www.d1softballnews.com/wp-content/uploads/2020/11/jenniffer-lopez-218x150.jpg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.d1softballnews.com/j-los-skincare-line-is-coming-and-no-one-will-age-quite-like-her/" rel="bookmark" title="JENNIFER LOPEZ&#8217;S SKINCARE LINE IS COMING &#8211; AND NO ONE WILL AGE QUITE LIKE HER" data-wpel-link="internal">JENNIFER LOPEZ&#8217;S SKINCARE LINE IS COMING &#8211; AND NO ONE WILL AGE QUITE LIKE HER</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.d1softballnews.com/bts-watch-the-first-teaser-of-the-life-goes-on-video-directed-by-jungkook/" rel="bookmark" class="td-image-wrap " title="BTS: WATCH THE FIRST TEASER OF THE &#8220;LIFE GOES ON&#8221; VIDEO DIRECTED BY JUNGKOOK"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="BTS: WATCH THE FIRST TEASER OF THE &#8220;LIFE GOES ON&#8221; VIDEO DIRECTED BY JUNGKOOK" data-type="image_tag" data-img-url="http://www.d1softballnews.com/wp-content/uploads/2020/11/bts-2-218x150.jpg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.d1softballnews.com/bts-watch-the-first-teaser-of-the-life-goes-on-video-directed-by-jungkook/" rel="bookmark" title="BTS: WATCH THE FIRST TEASER OF THE &#8220;LIFE GOES ON&#8221; VIDEO DIRECTED BY JUNGKOOK" data-wpel-link="internal">BTS: WATCH THE FIRST TEASER OF THE &#8220;LIFE GOES ON&#8221; VIDEO DIRECTED BY JUNGKOOK</a></h3> </div>
</div>
</div> </div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_2_c9b" data-td_block_id="tdi_2_c9b"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-tdi_2_c9b" data-td_block_id="tdi_2_c9b"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> 
<div class="comments" id="comments">
</div> 
</div>
</div>
<div class="td-pb-span4 td-main-sidebar" role="complementary">
<div class="td-ss-main-sidebar">
<aside id="search-2" class="td_block_template_1 widget search-2 widget_search"><form method="get" class="td-search-form-widget" action="http://www.d1softballnews.com/">
<div role="search">
<input class="td-widget-search-input" type="text" value="" name="s" id="s" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="searchsubmit" value="Search" />
</div>
</form></aside><aside id="custom_html-2" class="widget_text td_block_template_1 widget custom_html-2 widget_custom_html"><div class="textwidget custom-html-widget">
<div id="M509325ScriptRootC1027198">
</div>
<script src="https://jsc.mgid.com/d/1/d1softballnews.com.1027198.js" async></script>
</div></aside>
<aside id="recent-posts-2" class="td_block_template_1 widget recent-posts-2 widget_recent_entries">
<h4 class="block-title"><span>Recent Posts</span></h4>
<ul>
<li>
<a href="http://www.d1softballnews.com/the-elder-scrolls-5-skyrim-special-edition-computer-game-full-version-free-download/" data-wpel-link="internal">The Elder Scrolls 5 Skyrim Special Edition COMPUTER Game Full Version Free Download</a>
</li>
<li>
<a href="http://www.d1softballnews.com/scarface-the-world-is-yours-computer-game-free-download-latest-version/" data-wpel-link="internal">Scarface The World Is Yours COMPUTER Game Free Download Latest Version</a>
</li>
<li>
<a href="http://www.d1softballnews.com/motogp-19-computer-latest-version-free-download-2020/" data-wpel-link="internal">MotoGP 19 COMPUTER Latest Version Free Download 2020 </a>
</li>
<li>
<a href="http://www.d1softballnews.com/metal-gear-solid-v-the-phantom-pain-game-computer-game-latest-version/" data-wpel-link="internal">Metal Gear Solid V The Phantom Pain Game COMPUTER Game Latest Version</a>
</li>
<li>
<a href="http://www.d1softballnews.com/layers-of-fear-2-codex-computer-game-latest-version-free-download/" data-wpel-link="internal">Layers of Fear 2 Codex COMPUTER Game Latest Version Free Download</a>
</li>
</ul>
</aside> </div>
</div>
</div> 
</div> 
</div> 

<div class="tdc-footer-wrap ">


<div class="td-sub-footer-container td-container-wrap ">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span td-sub-footer-menu">
<div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="td-subfooter-menu"><li id="menu-item-31" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-31"><a href="http://www.d1softballnews.com/about-us/" data-wpel-link="internal">About Us</a></li>
<li id="menu-item-30" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy td-menu-item td-normal-menu menu-item-30"><a href="http://www.d1softballnews.com/privacy-policy/" data-wpel-link="internal">Privacy Policy</a></li>
<li id="menu-item-32" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-32"><a href="http://www.d1softballnews.com/contact-us/" data-wpel-link="internal">Contact Us</a></li>
<li id="menu-item-69684" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-69684"><a href="http://www.d1softballnews.com/dmca-policy/" data-wpel-link="internal">DMCA Policy</a></li>
</ul></div> </div>
<div class="td-pb-span td-sub-footer-copy">
&copy; 2019 D1 Softball News - All Rights Reserved. </div>
</div>
</div>
</div>
</div>
</div>
<script type="text/javascript">
   if(typeof quadsOptions !== 'undefined' && typeof wpquads_adblocker_check_2 
  === 'undefined' && quadsOptions.quadsChoice == 'ad_blocker_message'){

  var addEvent1 = function (obj, type, fn) {
      if (obj.addEventListener)
          obj.addEventListener(type, fn, false);
      else if (obj.attachEvent)
          obj.attachEvent('on' + type, function () {
              return fn.call(obj, window.event);
          });
  };
   addEvent1(window, 'load', function () {
      if (typeof wpquads_adblocker_check_2 === "undefined" || wpquads_adblocker_check_2 === false) {
          highlight_adblocked_ads();
      }
  });

   function highlight_adblocked_ads() {
      try {
          var ad_wrappers = document.querySelectorAll('div[id^="quads-ad"]')
      } catch (e) {
          return;
      }

      for (i = 0; i < ad_wrappers.length; i++) {
          ad_wrappers[i].className += ' quads-highlight-adblocked';
          ad_wrappers[i].className = ad_wrappers[i].className.replace('quads-location', '');
          ad_wrappers[i].setAttribute('style', 'display:block !important');
      }
  }
 }

(function() {
//Adblocker Notice Script Starts Here
var curr_url = window.location.href;
var red_ulr = localStorage.getItem('curr');
var modal = document.getElementById("quads-myModal");
var quadsAllowedCookie =  quadsgetCookie('quadsAllowedCookie');

if(typeof quadsOptions !== 'undefined' && typeof wpquads_adblocker_check_2 
  === 'undefined' ){

  if(quadsAllowedCookie!=quadsOptions.allow_cookies){
    quadssetCookie('quadsCookie', '', -1, '/');
    quadssetCookie('quadsAllowedCookie', quadsOptions.allow_cookies, 1, '/');
  }

  if(quadsOptions.allow_cookies == 2){
    if( quadsOptions.quadsChoice == 'bar' || quadsOptions.quadsChoice == 'popup'){
        modal.style.display = "block";
        quadssetCookie('quadsCookie', '', -1, '/');
    }
    
    if(quadsOptions.quadsChoice == 'page_redirect' && quadsOptions.page_redirect !="undefined"){
        if(red_ulr==null || curr_url!=quadsOptions.page_redirect){
        window.location = quadsOptions.page_redirect;
        localStorage.setItem('curr',quadsOptions.page_redirect);
      }
    }
  }else{
    var adsCookie = quadsgetCookie('quadsCookie');
    if(adsCookie==false) {
      if( quadsOptions.quadsChoice == 'bar' || quadsOptions.quadsChoice == 'popup'){
          modal.style.display = "block";
      }
      if(quadsOptions.quadsChoice == 'page_redirect' && quadsOptions.page_redirect !="undefined"){
        window.location = quadsOptions.page_redirect;
        quadssetCookie('quadsCookie', true, 1, '/');
      }
    }else{
      modal.style.display = "none";
    }
  }
}



var span = document.getElementsByClassName("quads-cls-notice")[0];
if(span){
  span.onclick = function() {
    modal.style.display = "none";
    document.cookie = "quads_prompt_close="+new Date();
    quadssetCookie('quadsCookie', 'true', 1, '/');
  }
}

window.onclick = function(event) {
  if (event.target == modal) {
    modal.style.display = "none";
    document.cookie = "quads_prompt_close="+new Date();
    quadssetCookie('quadsCookie', 'true', 1, '/');
  }
}
})();
function quadsgetCookie(cname){
    var name = cname + '=';
    var ca = document.cookie.split(';');
    for (var i = 0; i < ca.length; i++) {
        var c = ca[i].trim();
        if (c.indexOf(name) === 0) {
            return c.substring(name.length, c.length);
        }
    }
    return false;
}
function quadssetCookie(cname, cvalue, exdays, path){
  var d = new Date();
  d.setTime(d.getTime() + (exdays*24*60*60*1000));
  var expires = "expires="+ d.toUTCString();
  document.cookie = cname + "=" + cvalue + ";" + expires + ";path=/";
}
//Adblocker Notice Script Ends Here
</script>

<script type='text/javascript' src='http://www.d1softballnews.com/wp-content/plugins/metronet-profile-picture/js/mpp-frontend.js?ver=2.3.11' id='mpp_gutenberg_tabs-js'></script>
<script type='text/javascript' id='contact-form-7-js-extra'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"http:\/\/www.d1softballnews.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.d1softballnews.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.3' id='contact-form-7-js'></script>
<script type='text/javascript' src='http://www.d1softballnews.com/wp-includes/js/underscore.min.js?ver=1.8.3' id='underscore-js'></script>
<script type='text/javascript' src='http://www.d1softballnews.com/wp-content/plugins/td-cloud-library/assets/js/js_posts_autoload.min.js?ver=53f7b7675c3127e69efacf5620821cc8' id='tdb_js_posts_autoload-js'></script>
<script type='text/javascript' src='http://www.d1softballnews.com/wp-content/plugins/td-composer/legacy/Newspaper/js/tagdiv_theme.min.js?ver=10.3.7' id='td-site-min-js'></script>
<script type='text/javascript' src='http://www.d1softballnews.com/wp-includes/js/comment-reply.min.js?ver=5.5.3' id='comment-reply-js'></script>
<script type='text/javascript' src='http://www.d1softballnews.com/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=53f7b7675c3127e69efacf5620821cc8' id='tdb_js_files_for_front-js'></script>
<script type='text/javascript' src='http://www.d1softballnews.com/wp-includes/js/wp-embed.min.js?ver=5.5.3' id='wp-embed-js'></script>
<script type='text/javascript' id='fifu-image-js-js-extra'>
/* <![CDATA[ */
var fifuImageVars = {"fifu_lazy":"","fifu_woo_lbox_enabled":"1","fifu_woo_zoom":"inline","fifu_is_product":"","fifu_is_flatsome_active":"","fifu_rest_url":"http:\/\/www.d1softballnews.com\/wp-json\/","fifu_nonce":"762c9015cb"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.d1softballnews.com/wp-content/plugins/featured-image-from-url/includes/html/js/image.js?ver=3.4.2' id='fifu-image-js-js'></script>

<script>
    
</script>
</body>
</html>