<!DOCTYPE html><html lang=en-US><head> <script async src="https://www.googletagmanager.com/gtag/js?id=UA-131292421-2"></script> <script>window.dataLayer=window.dataLayer||[];function gtag(){dataLayer.push(arguments);}
gtag('js',new Date());gtag('config','UA-131292421-2');</script> <meta charset="UTF-8"><meta name="viewport" id="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no"><link rel="shortcut icon" href=http://www.d1softballnews.com/wp-content/uploads/2020/12/d1favi.png><link rel=alternate type=application/rss+xml title="RSS 2.0" href=http://www.d1softballnews.com/feed/><link rel=alternate type=text/xml title="RSS .92" href=http://www.d1softballnews.com/feed/rss/><link rel=alternate type=application/atom+xml title="Atom 0.3" href=http://www.d1softballnews.com/feed/atom/><link rel=pingback href=http://www.d1softballnews.com/xmlrpc.php><meta property="og:image" content="http://www.d1softballnews.com/wp-content/uploads/2021/05/spears-1000x600.jpg"><meta name="twitter:image" content="http://www.d1softballnews.com/wp-content/uploads/2021/05/spears-1000x600.jpg"><meta property="og:type" content="article"><meta property="og:description" content="Pink is happy to see that something is changing for the girls, compared to when she took her first steps in music. In an interview with People, the 41-year-old singer reflected on when she was compared and put against colleagues like Britney Spears and Christina Aguilera early in their careers: &#8220;It was so unfair to all girls &#8211; she said &#8211; None [&hellip;]"><meta name="twitter:card" content="summary"><meta name="twitter:url" content="http://www.d1softballnews.com/pink-recalled-when-she-was-put-against-britney-spears-and-christina-aguilera-early-in-their-careers/"><meta name="twitter:title" content="PINK RECALLED WHEN SHE WAS PUT AGAINST BRITNEY SPEARS AND CHRISTINA AGUILERA EARLY IN THEIR CAREERS"><meta name="twitter:description" content="Pink is happy to see that something is changing for the girls, compared to when she took her first steps in music. In an interview with People, the 41-year-old singer reflected on when she was compared and put against colleagues like Britney Spears and Christina Aguilera early in their careers: &#8220;It was so unfair to all girls &#8211; she said &#8211; None [&hellip;]"><title>PINK RECALLED WHEN SHE WAS PUT AGAINST BRITNEY SPEARS AND CHRISTINA AGUILERA EARLY IN THEIR CAREERS &#8211; D1SoftballNews.com</title><meta name='robots' content='max-image-preview:large'><link rel=amphtml href=http://www.d1softballnews.com/pink-recalled-when-she-was-put-against-britney-spears-and-christina-aguilera-early-in-their-careers/amp/><meta name="generator" content="AMP for WP 1.0.77"><link rel=dns-prefetch href=//netdna.bootstrapcdn.com><link rel=dns-prefetch href=//fonts.googleapis.com><link rel=dns-prefetch href=//s.w.org><link rel=alternate type=application/rss+xml title="D1SoftballNews.com &raquo; Feed" href=http://www.d1softballnews.com/feed/> <script>window._wpemojiSettings={"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.d1softballnews.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7.2"}};!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);</script> <style>img.wp-smiley,img.emoji{display:inline !important;border:none !important;box-shadow:none !important;height:1em !important;width:1em !important;margin:0
.07em !important;vertical-align:-0.1em !important;background:none !important;padding:0
!important}</style><link rel=stylesheet href=http://www.d1softballnews.com/wp-content/cache/minify/0d32c.css media=all><link rel=stylesheet id=mvp-fontawesome-css href='//netdna.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.css?ver=5.7.2' type=text/css media=all><link rel=stylesheet href=http://www.d1softballnews.com/wp-content/cache/minify/f0b0d.css media=all><!--[if lt IE 10]><link rel=stylesheet id=mvp-iecss-css  href='http://www.d1softballnews.com/wp-content/themes/flex-mag/css/iecss.css?ver=5.7.2' type=text/css media=all> <![endif]--><link rel=stylesheet id=mvp-fonts-css href='//fonts.googleapis.com/css?family=Oswald%3A400%2C700%7CLato%3A400%2C700%7CWork+Sans%3A900%7CMontserrat%3A400%2C700%7COpen+Sans%3A800%7CPlayfair+Display%3A400%2C700%2C900%7CQuicksand%7CRaleway%3A200%2C400%2C700%7CRoboto+Slab%3A400%2C700%7CWork+Sans%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CMontserrat%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CWork+Sans%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CLato%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CMontserrat%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%26subset%3Dlatin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Cvietnamese' type=text/css media=all><link rel=stylesheet href=http://www.d1softballnews.com/wp-content/cache/minify/8d614.css media=all><style id=quads-styles-inline-css>.quads-ad-label{font-size:12px;text-align:center;color:#333}</style> <script src=http://www.d1softballnews.com/wp-content/cache/minify/818c0.js></script> <link rel=https://api.w.org/ href=http://www.d1softballnews.com/wp-json/><link rel=alternate type=application/json href=http://www.d1softballnews.com/wp-json/wp/v2/posts/94140><link rel=EditURI type=application/rsd+xml title=RSD href=http://www.d1softballnews.com/xmlrpc.php?rsd><link rel=wlwmanifest type=application/wlwmanifest+xml href=http://www.d1softballnews.com/wp-includes/wlwmanifest.xml><meta name="generator" content="WordPress 5.7.2"><link rel=canonical href=http://www.d1softballnews.com/pink-recalled-when-she-was-put-against-britney-spears-and-christina-aguilera-early-in-their-careers/><link rel=shortlink href='http://www.d1softballnews.com/?p=94140'><link rel=alternate type=application/json+oembed href="http://www.d1softballnews.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.d1softballnews.com%2Fpink-recalled-when-she-was-put-against-britney-spears-and-christina-aguilera-early-in-their-careers%2F"><link rel=alternate type=text/xml+oembed href="http://www.d1softballnews.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.d1softballnews.com%2Fpink-recalled-when-she-was-put-against-britney-spears-and-christina-aguilera-early-in-their-careers%2F&#038;format=xml"> <script>document.cookie='quads_browser_width='+screen.width;</script> <style>#wallpaper{background:url() no-repeat 50% 0}body,
.blog-widget-text p,
.feat-widget-text p,
.post-info-right,
span.post-excerpt,
span.feat-caption,
span.soc-count-text,
#content-main p,
#commentspopup .comments-pop,
.archive-list-text p,
.author-box-bot p,
#post-404 p,
.foot-widget,
#home-feat-text p,
.feat-top2-left-text p,
.feat-wide1-text p,
.feat-wide4-text p,
#content-main table,
.foot-copy p,
.video-main-text
p{font-family:'Lato',sans-serif}a,
a:visited,
.post-info-name
a{color:#eb0254}a:hover{color:#999}.fly-but-wrap,
span.feat-cat,
span.post-head-cat,
.prev-next-text a,
.prev-next-text a:visited,
.prev-next-text a:hover{background:#eb0254}.fly-but-wrap{background:#eb0254}.fly-but-wrap
span{background:#fff}.woocommerce .star-rating span:before{color:#eb0254}.woocommerce .widget_price_filter .ui-slider .ui-slider-range,
.woocommerce .widget_price_filter .ui-slider .ui-slider-handle{background-color:#eb0254}.woocommerce span.onsale,
.woocommerce #respond input#submit.alt,
.woocommerce a.button.alt,
.woocommerce button.button.alt,
.woocommerce input.button.alt,
.woocommerce #respond input#submit.alt:hover,
.woocommerce a.button.alt:hover,
.woocommerce button.button.alt:hover,
.woocommerce input.button.alt:hover{background-color:#eb0254}span.post-header{border-top:4px solid #eb0254}#main-nav-wrap,nav.main-menu-wrap,.nav-logo,.nav-right-wrap,.nav-menu-out,.nav-logo-out,#head-main-top{-webkit-backface-visibility:hidden;background:#eb0254}nav.main-menu-wrap ul li a,
.nav-menu-out:hover ul li:hover a,
.nav-menu-out:hover span.nav-search-but:hover i,
.nav-menu-out:hover span.nav-soc-but:hover i,
span.nav-search-but i,
span.nav-soc-but
i{color:#fff}.nav-menu-out:hover li.menu-item-has-children:hover a:after,
nav.main-menu-wrap ul li.menu-item-has-children a:after{border-color:#fff transparent transparent transparent}.nav-menu-out:hover ul li a,
.nav-menu-out:hover span.nav-search-but i,
.nav-menu-out:hover span.nav-soc-but
i{color:#fdacc8}.nav-menu-out:hover li.menu-item-has-children a:after{border-color:#fdacc8 transparent transparent transparent}.nav-menu-out:hover ul li ul.mega-list li a,
.side-list-text p,
.row-widget-text p,
.blog-widget-text h2,
.feat-widget-text h2,
.archive-list-text h2,
h2.author-list-head a,
.mvp-related-text
a{color:#222}ul.mega-list li:hover a,
ul.side-list li:hover .side-list-text p,
ul.row-widget-list li:hover .row-widget-text p,
ul.blog-widget-list li:hover .blog-widget-text h2,
.feat-widget-wrap:hover .feat-widget-text h2,
ul.archive-list li:hover .archive-list-text h2,
ul.archive-col-list li:hover .archive-list-text h2,
h2.author-list-head a:hover,
.mvp-related-posts ul li:hover .mvp-related-text
a{color:#999 !important}span.more-posts-text,
a.inf-more-but,
#comments-button a,
#comments-button span.comment-but-text{border:1px
solid #eb0254}span.more-posts-text,
a.inf-more-but,
#comments-button a,
#comments-button span.comment-but-text{color:#eb0254 !important}#comments-button a:hover,
#comments-button span.comment-but-text:hover,a.inf-more-but:hover,span.more-posts-text:hover{background:#eb0254}nav.main-menu-wrap ul li a,
ul.col-tabs li a,
nav.fly-nav-menu ul li a,
.foot-menu .menu li
a{font-family:'Montserrat',sans-serif}.feat-top2-right-text h2,
.side-list-text p,
.side-full-text p,
.row-widget-text p,
.feat-widget-text h2,
.blog-widget-text h2,
.prev-next-text a,
.prev-next-text a:visited,
.prev-next-text a:hover,
span.post-header,
.archive-list-text h2,
#woo-content h1.page-title,
.woocommerce div.product .product_title,
.woocommerce ul.products li.product h3,
.video-main-text h2,
.mvp-related-text
a{font-family:'Montserrat',sans-serif}.feat-wide-sub-text h2,
#home-feat-text h2,
.feat-top2-left-text h2,
.feat-wide1-text h2,
.feat-wide4-text h2,
.feat-wide5-text h2,
h1.post-title,
#content-main h1.post-title,
#post-404 h1,
h1.post-title-wide,
#content-main blockquote p,
#commentspopup #content-main
h1{font-family:'Work Sans',sans-serif}h3.home-feat-title,
h3.side-list-title,
#infscr-loading,
.score-nav-menu select,
h1.cat-head,
h1.arch-head,
h2.author-list-head,
h3.foot-head,
.woocommerce ul.product_list_widget span.product-title,
.woocommerce ul.product_list_widget li a,
.woocommerce #reviews #comments ol.commentlist li .comment-text p.meta,
.woocommerce .related h2,
.woocommerce div.product .woocommerce-tabs .panel h2,
.woocommerce div.product .product_title,
#content-main h1,
#content-main h2,
#content-main h3,
#content-main h4,
#content-main h5,
#content-main
h6{font-family:'Work Sans',sans-serif}</style><style>.post-cont-out,.post-cont-in{margin-right:0}.nav-links{display:none}</style></head><body class="post-template-default single single-post postid-94140 single-format-standard wp-embed-responsive"><div id=site class="left relative"><div id=site-wrap class="left relative"><div id=fly-wrap><div class=fly-wrap-out><div class=fly-side-wrap><ul class="fly-bottom-soc left relative"> <li class=twit-soc> <a href=https://twitter.com/D1softballN target=_blank> <i class="fa fa-twitter fa-2"></i> </a> </li> <li class=rss-soc> <a href=http://www.d1softballnews.com/feed/rss/ target=_blank> <i class="fa fa-rss fa-2"></i> </a> </li></ul></div><div class=fly-wrap-in><div id=fly-menu-wrap><nav class="fly-nav-menu left relative"><div class=menu><ul> <li class="page_item page-item-7"><a href=http://www.d1softballnews.com/about-us/>About Us</a></li> <li class="page_item page-item-27"><a href=http://www.d1softballnews.com/contact-us/>Contact Us</a></li> <li class="page_item page-item-69681"><a href=http://www.d1softballnews.com/dmca-policy/>DMCA Policy</a></li> <li class="page_item page-item-33"><a href=http://www.d1softballnews.com/>Home</a></li> <li class="page_item page-item-3"><a href=http://www.d1softballnews.com/privacy-policy/>Privacy Policy</a></li></ul></div></nav></div></div></div></div><div id=head-main-wrap class="left relative"><div id=head-main-top class="left relative"><div class=leader-wrap-out><div class=leader-wrap-in><div id=leader-wrap class="left relative"><style>#M509325ScriptRootC1053051{min-height:300px}</style><div id=M509325ScriptRootC1053051></div> <script src=https://jsc.mgid.com/d/1/d1softballnews.com.1053051.js async></script> </div></div></div></div><div id=main-nav-wrap><div class=nav-out><div class=nav-in><div id=main-nav-cont class=left itemscope itemtype=http://schema.org/Organization><div class=nav-logo-out><div class="nav-left-wrap left relative"><div class="fly-but-wrap left relative"> <span></span> <span></span> <span></span> <span></span></div><div class="nav-logo left"> <a itemprop=url href=http://www.d1softballnews.com/><img itemprop=logo src=http://www.d1softballnews.com/wp-content/uploads/2020/12/d1softlogo.png alt=D1SoftballNews.com data-rjs=2></a><h2 class="mvp-logo-title">D1SoftballNews.com</h2></div></div><div class=nav-logo-in><div class=nav-menu-out><div class=nav-menu-in><nav class="main-menu-wrap left"><div class=menu-header-menu-container><ul id=menu-header-menu class=menu><li id=menu-item-17 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17"><a href=http://www.d1softballnews.com/category/news/>NEWS</a></li> <li id=menu-item-16 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16"><a href=http://www.d1softballnews.com/category/gaming/>GAMING</a></li> <li id=menu-item-19 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19"><a href=http://www.d1softballnews.com/category/technology/>TECH</a></li> <li id=menu-item-15 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15"><a href=http://www.d1softballnews.com/category/entertainment/>ENTERTAINMENT</a></li> <li id=menu-item-12656 class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-12656"><a href=http://www.d1softballnews.com/category/celebrities/>CELEBRITIES</a></li></ul></div></nav></div><div class="nav-right-wrap relative"><div class="nav-search-wrap left relative"> <span class="nav-search-but left"><i class="fa fa-search fa-2"></i></span><div class=search-fly-wrap><form method=get id=searchform action=http://www.d1softballnews.com/> <input type=text name=s id=s value="Type search term and press enter" onfocus='if (this.value == "Type search term and press enter") { this.value = ""; }' onblur='if (this.value == "") { this.value = "Type search term and press enter"; }'> <input type=hidden id=searchsubmit value=Search></form></div></div> <a href=https://twitter.com/D1softballN target=_blank> <span class=nav-soc-but><i class="fa fa-twitter fa-2"></i></span> </a></div></div></div></div></div></div></div></div></div><div id=body-main-wrap class="left relative" itemscope itemtype=http://schema.org/NewsArticle><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="http://www.d1softballnews.com/pink-recalled-when-she-was-put-against-britney-spears-and-christina-aguilera-early-in-their-careers/"><div class="body-main-out relative"><div class=body-main-in><div id=body-main-cont class="left relative"><div id=post-main-wrap class="left relative"><div class=post-wrap-out1><div class=post-wrap-in1><div id=post-left-col class=relative><article id=post-area class="post-94140 post type-post status-publish format-standard has-post-thumbnail hentry category-celebrities tag-britney-spears tag-christina-aguilera"><header id=post-header> <a class=post-cat-link href=http://www.d1softballnews.com/category/celebrities/><span class=post-head-cat>CELEBRITIES</span></a><h1 class="post-title entry-title left" itemprop="headline">PINK RECALLED WHEN SHE WAS PUT AGAINST BRITNEY SPEARS AND CHRISTINA AGUILERA EARLY IN THEIR CAREERS</h1><div id=post-info-wrap class="left relative"><div class=post-info-out><div class="post-info-img left relative"> <img alt src="https://0.gravatar.com/avatar/6b953f83dcdfdb3fdf1a151f78bf11a5?s=50&#038;d=mm&#038;r=g" srcset='http://0.gravatar.com/avatar/6b953f83dcdfdb3fdf1a151f78bf11a5?s=100&#038;d=mm&#038;r=g 2x' class='avatar avatar-50 photo' height=50 width=50 loading=lazy></div><div class=post-info-in><div class="post-info-right left relative"><div class="post-info-name left relative" itemprop=author itemscope itemtype=https://schema.org/Person> <span class=post-info-text>By</span> <span class="author-name vcard fn author" itemprop=name><a href=http://www.d1softballnews.com/author/d1-soft/ title="Posts by D1 Soft Ball News" rel=author>D1 Soft Ball News</a></span> <span class=author-email><a href="/cdn-cgi/l/email-protection#dfacabbeb9b99fbbeeacb0b9abbdbeb3b3b1baa8acf1bcb0b2"><i class="fa fa-envelope fa-2"></i></a></span></div><div class="post-info-date left relative"> <span class=post-info-text>Posted on</span> <span class="post-date updated"><time class="post-date updated" itemprop=datePublished datetime=2021-05-18>May 18, 2021</time></span><meta itemprop="dateModified" content="2021-05-18"></div></div></div></div></div></header><div id=post-feat-img class="left relative" itemprop=image itemscope itemtype=https://schema.org/ImageObject> <img width=1280 height=719 src=http://www.d1softballnews.com/wp-content/uploads/2021/05/spears.jpg class="attachment- size- wp-post-image" alt loading=lazy srcset="http://www.d1softballnews.com/wp-content/uploads/2021/05/spears.jpg 1280w, http://www.d1softballnews.com/wp-content/uploads/2021/05/spears-300x169.jpg 300w, http://www.d1softballnews.com/wp-content/uploads/2021/05/spears-1024x575.jpg 1024w, http://www.d1softballnews.com/wp-content/uploads/2021/05/spears-768x431.jpg 768w" sizes="(max-width: 1280px) 100vw, 1280px"><meta itemprop="url" content="http://www.d1softballnews.com/wp-content/uploads/2021/05/spears.jpg"><meta itemprop="width" content="1280"><meta itemprop="height" content="719"><div class=post-feat-text></div></div><div id=content-area itemprop=articleBody class="post-94140 post type-post status-publish format-standard has-post-thumbnail hentry category-celebrities tag-britney-spears tag-christina-aguilera"><div class=post-cont-out><div class=post-cont-in><div id=content-main class="left relative"><section class=social-sharing-top> <a href=# onclick="window.open('http://www.facebook.com/sharer.php?u=http://www.d1softballnews.com/pink-recalled-when-she-was-put-against-britney-spears-and-christina-aguilera-early-in-their-careers/&amp;t=PINK RECALLED WHEN SHE WAS PUT AGAINST BRITNEY SPEARS AND CHRISTINA AGUILERA EARLY IN THEIR CAREERS', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><div class=facebook-share><span class=fb-but1><i class="fa fa-facebook fa-2"></i></span><span class=social-text>Share</span></div></a> <a href=# onclick="window.open('http://twitter.com/share?text=PINK RECALLED WHEN SHE WAS PUT AGAINST BRITNEY SPEARS AND CHRISTINA AGUILERA EARLY IN THEIR CAREERS -&amp;url=http://www.d1softballnews.com/pink-recalled-when-she-was-put-against-britney-spears-and-christina-aguilera-early-in-their-careers/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><div class=twitter-share><span class=twitter-but1><i class="fa fa-twitter fa-2"></i></span><span class=social-text>Tweet</span></div></a> <a href="whatsapp://send?text=PINK RECALLED WHEN SHE WAS PUT AGAINST BRITNEY SPEARS AND CHRISTINA AGUILERA EARLY IN THEIR CAREERS http://www.d1softballnews.com/pink-recalled-when-she-was-put-against-britney-spears-and-christina-aguilera-early-in-their-careers/"><div class=whatsapp-share><span class=whatsapp-but1><i class="fa fa-whatsapp fa-2"></i></span><span class=social-text>Share</span></div></a> <a href=# onclick="window.open('http://pinterest.com/pin/create/button/?url=http://www.d1softballnews.com/pink-recalled-when-she-was-put-against-britney-spears-and-christina-aguilera-early-in-their-careers/&amp;media=http://www.d1softballnews.com/wp-content/uploads/2021/05/spears-1000x600.jpg&amp;description=PINK RECALLED WHEN SHE WAS PUT AGAINST BRITNEY SPEARS AND CHRISTINA AGUILERA EARLY IN THEIR CAREERS', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"><div class=pinterest-share><span class=pinterest-but1><i class="fa fa-pinterest-p fa-2"></i></span><span class=social-text>Share</span></div></a> <a href="/cdn-cgi/l/email-protection#af90dcdacdc5caccdb92ffe6e1e48ffdeaeceee3e3eaeb8ff8e7eae18ffce7ea8ff8eefc8ffffafb8feee8eee6e1fcfb8fedfde6fbe1eaf68ffcffeaeefdfc8feee1eb8fece7fde6fcfbe6e1ee8feee8fae6e3eafdee8feaeefde3f68fe6e18ffbe7eae6fd8feceefdeaeafdfc89cec2df94ede0ebf692e68fc9c0dac1cb8fdbc7c6dc8fcedddbc6ccc3ca8fc6c1dbcaddcadcdbc6c1c88fcec1cb8fdbc7c0dac8c7db8fc0c98fdcc7ceddc6c1c88fc6db8fd8c6dbc78fd6c0da818fecc7caccc48fc6db8fc0dadb958fc7dbdbdf958080d8d8d881cb9edcc0c9dbcdcec3c3c1cad8dc81ccc0c280dfc6c1c482ddcacccec3c3cacb82d8c7cac182dcc7ca82d8cedc82dfdadb82cec8cec6c1dcdb82cdddc6dbc1cad682dcdfcacedddc82cec1cb82ccc7ddc6dcdbc6c1ce82cec8dac6c3caddce82caceddc3d682c6c182dbc7cac6dd82ccceddcacadddc80"><div class=email-share><span class=email-but><i class="fa fa-envelope fa-2"></i></span><span class=social-text>Email</span></div></a> <a href=http://www.d1softballnews.com/pink-recalled-when-she-was-put-against-britney-spears-and-christina-aguilera-early-in-their-careers/#respond><div class="social-comments comment-click-94140"><i class="fa fa-commenting fa-2"></i><span class=social-text-com>Comments</span></div></a></section><div class="quads-location quads-ad1" id=quads-ad1 style=float:none;margin:3px;><style>#M509325ScriptRootC1053051{min-height:300px}</style><div id=M509325ScriptRootC1053051></div> <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script src=https://jsc.mgid.com/d/1/d1softballnews.com.1053051.js async></script> </div><p><strong>Pink </strong>is happy to see that something is changing for the girls, compared to when she took her first steps in music.</p><p>In an interview with <em>People, </em>the 41-year-old singer reflected on when she was compared and put against colleagues like Britney Spears and <strong>Christina Aguilera</strong> early in their <strong>careers:</strong> &#8220;<strong><em>It was so unfair to all girls</em> </strong>&#8211; she said &#8211; None of us wanted <em>that.</em>&#8221;</p><p>Pink went on to recall a certain narrative that at the time painted her as &#8220;<em>the anti-Britney</em>&#8220;: <strong>&#8220;</strong>I love Britney and she used to go around with my<em><strong> albums.</strong> I thought, &#8216;Guys, I&#8217;m street punk, I&#8217;m a skateboarding guy. <strong>That&#8217;s not to say you&#8217;re the anti-Britney. I don&#8217;t want to fight anyone.&#8221;</strong></em></p><div class="quads-location quads-ad2" id=quads-ad2 style=float:none;margin:3px;><div id=M509325ScriptRootC990890></div> <script src=https://jsc.mgid.com/d/1/d1softballnews.com.990890.js async></script> </div><p>Good advice had helped her deal with the situation: &#8221; One of the<em> best things L.A. Reid [music producer under whose Label LaFace released<strong> Pink&#8217;s</strong>first album &#8220;Can&#8217;t Take Me Home&#8221; in 2000]</em>ever told me is that the music industry is big enough for everyone to win at the same time. &#8221;</p><p>&#8220;<em>I think we got away with it the way 20-year-old girls could do</em>,&#8221; the artist added, before noting that, &#8220;<em>Now it&#8217;s totally different.<strong> It&#8217;s nice that girls support girls and I love seeing this.&#8221;</strong></em></p><p><iframe loading=lazy title="P!nk - All I Know So Far (Official Video)" width=1000 height=563 src="https://www.youtube.com/embed/Xuy-V_3V-4g?feature=oembed" frameborder=0 allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p><p>Pink recently released the<strong> </strong>new song &#8220;<strong>All I Know So Far</strong>&#8221; as an advance on the new recording project titled &#8220;All I Know So Far: Setlist&#8221;, coming May<strong> 21.</strong></p><p>The same day the documentary &#8220;All I Know So Far&#8221; will also arrive on Amazon Prime Video.<div class="quads-location quads-ad3" id=quads-ad3 style=float:none;margin:3px;><div id=M509325ScriptRootC1027202></div> <script src=https://jsc.mgid.com/d/1/d1softballnews.com.1027202.js async></script> </div><div class=mvp-org-wrap itemprop=publisher itemscope itemtype=https://schema.org/Organization><div class=mvp-org-logo itemprop=logo itemscope itemtype=https://schema.org/ImageObject> <img src=http://www.d1softballnews.com/wp-content/uploads/2020/12/d1softlogo.png><meta itemprop="url" content="http://www.d1softballnews.com/wp-content/uploads/2020/12/d1softlogo.png"></div><meta itemprop="name" content="D1SoftballNews.com"></div><div class=posts-nav-link></div><div class=post-tags> <span class=post-tags-header>Related Items:</span><span itemprop=keywords><a href=http://www.d1softballnews.com/tag/britney-spears/ rel=tag>Britney Spears</a>, <a href=http://www.d1softballnews.com/tag/christina-aguilera/ rel=tag>Christina Aguilera</a></span></div><div class=social-sharing-bot> <a href=# onclick="window.open('http://www.facebook.com/sharer.php?u=http://www.d1softballnews.com/pink-recalled-when-she-was-put-against-britney-spears-and-christina-aguilera-early-in-their-careers/&amp;t=PINK RECALLED WHEN SHE WAS PUT AGAINST BRITNEY SPEARS AND CHRISTINA AGUILERA EARLY IN THEIR CAREERS', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><div class=facebook-share><span class=fb-but1><i class="fa fa-facebook fa-2"></i></span><span class=social-text>Share</span></div></a> <a href=# onclick="window.open('http://twitter.com/share?text=PINK RECALLED WHEN SHE WAS PUT AGAINST BRITNEY SPEARS AND CHRISTINA AGUILERA EARLY IN THEIR CAREERS -&amp;url=http://www.d1softballnews.com/pink-recalled-when-she-was-put-against-britney-spears-and-christina-aguilera-early-in-their-careers/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><div class=twitter-share><span class=twitter-but1><i class="fa fa-twitter fa-2"></i></span><span class=social-text>Tweet</span></div></a> <a href="whatsapp://send?text=PINK RECALLED WHEN SHE WAS PUT AGAINST BRITNEY SPEARS AND CHRISTINA AGUILERA EARLY IN THEIR CAREERS http://www.d1softballnews.com/pink-recalled-when-she-was-put-against-britney-spears-and-christina-aguilera-early-in-their-careers/"><div class=whatsapp-share><span class=whatsapp-but1><i class="fa fa-whatsapp fa-2"></i></span><span class=social-text>Share</span></div></a> <a href=# onclick="window.open('http://pinterest.com/pin/create/button/?url=http://www.d1softballnews.com/pink-recalled-when-she-was-put-against-britney-spears-and-christina-aguilera-early-in-their-careers/&amp;media=http://www.d1softballnews.com/wp-content/uploads/2021/05/spears-1000x600.jpg&amp;description=PINK RECALLED WHEN SHE WAS PUT AGAINST BRITNEY SPEARS AND CHRISTINA AGUILERA EARLY IN THEIR CAREERS', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"><div class=pinterest-share><span class=pinterest-but1><i class="fa fa-pinterest-p fa-2"></i></span><span class=social-text>Share</span></div></a> <a href="/cdn-cgi/l/email-protection#112e6264737b7472652c41585f5a31435452505d5d5455314659545f31425954314650423141444531505650585f424531534358455f54483142415450434231505f5531525943584245585f5031505644585d544350315450435d4831585f314559545843315250435454434237707c612a535e55482c5831777e647f7531657978623170636578727d7431787f657463746265787f7631707f753165797e64767965317e773162797063787f76317865316678657931687e643f31527974727a317865317e64652b31796565612b3e3e6666663f7520627e776573707d7d7f7466623f727e7c3e61787f7a3c637472707d7d74753c6679747f3c6279743c6670623c6164653c707670787f62653c736378657f74683c6261747063623c707f753c727963786265787f703c707664787d7463703c7470637d683c787f3c65797478633c727063747463623e"><div class=email-share><span class=email-but><i class="fa fa-envelope fa-2"></i></span><span class=social-text>Email</span></div></a></div><div class="mvp-related-posts left relative"><h4 class="post-header"><span class=post-header>Recommended for you</span></h4><ul> <li><div class="mvp-related-img left relative"> <a href=http://www.d1softballnews.com/kim-kardashian-called-to-the-rescue-by-britney-spears-fans/ rel=bookmark title="Kim Kardashian called to the rescue by Britney Spears fans!"> <img width=300 height=180 src=http://www.d1softballnews.com/wp-content/uploads/2021/02/kim-kardashian-3-300x180.jpg class="reg-img wp-post-image" alt loading=lazy srcset="http://www.d1softballnews.com/wp-content/uploads/2021/02/kim-kardashian-3-300x180.jpg 300w, http://www.d1softballnews.com/wp-content/uploads/2021/02/kim-kardashian-3-1000x600.jpg 1000w, http://www.d1softballnews.com/wp-content/uploads/2021/02/kim-kardashian-3-450x270.jpg 450w" sizes="(max-width: 300px) 100vw, 300px"> <img width=80 height=80 src=http://www.d1softballnews.com/wp-content/uploads/2021/02/kim-kardashian-3-80x80.jpg class="mob-img wp-post-image" alt loading=lazy srcset="http://www.d1softballnews.com/wp-content/uploads/2021/02/kim-kardashian-3-80x80.jpg 80w, http://www.d1softballnews.com/wp-content/uploads/2021/02/kim-kardashian-3-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px"> </a></div><div class="mvp-related-text left relative"> <a href=http://www.d1softballnews.com/kim-kardashian-called-to-the-rescue-by-britney-spears-fans/>Kim Kardashian called to the rescue by Britney Spears fans!</a></div> </li> <li><div class="mvp-related-img left relative"> <a href=http://www.d1softballnews.com/britney-spears-renews-herself-and-shows-her-new-look/ rel=bookmark title="Britney Spears renews herself and shows her new look"> <img width=300 height=180 src=http://www.d1softballnews.com/wp-content/uploads/2020/12/itney-300x180.jpg class="reg-img wp-post-image" alt loading=lazy srcset="http://www.d1softballnews.com/wp-content/uploads/2020/12/itney-300x180.jpg 300w, http://www.d1softballnews.com/wp-content/uploads/2020/12/itney-1000x600.jpg 1000w, http://www.d1softballnews.com/wp-content/uploads/2020/12/itney-450x270.jpg 450w" sizes="(max-width: 300px) 100vw, 300px"> <img width=80 height=80 src=http://www.d1softballnews.com/wp-content/uploads/2020/12/itney-80x80.jpg class="mob-img wp-post-image" alt loading=lazy srcset="http://www.d1softballnews.com/wp-content/uploads/2020/12/itney-80x80.jpg 80w, http://www.d1softballnews.com/wp-content/uploads/2020/12/itney-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px"> </a></div><div class="mvp-related-text left relative"> <a href=http://www.d1softballnews.com/britney-spears-renews-herself-and-shows-her-new-look/>Britney Spears renews herself and shows her new look</a></div> </li> <li><div class="mvp-related-img left relative"> <a href=http://www.d1softballnews.com/britney-spears-and-backstreet-boys-duet-for-the-first-time-in-new-single-matches/ rel=bookmark title="BRITNEY SPEARS AND BACKSTREET BOYS DUET FOR THE FIRST TIME IN NEW SINGLE &#8220;MATCHES&#8221;"> <img width=300 height=180 src=http://www.d1softballnews.com/wp-content/uploads/2020/12/britney-1-300x180.jpg class="reg-img wp-post-image" alt loading=lazy srcset="http://www.d1softballnews.com/wp-content/uploads/2020/12/britney-1-300x180.jpg 300w, http://www.d1softballnews.com/wp-content/uploads/2020/12/britney-1-1000x600.jpg 1000w, http://www.d1softballnews.com/wp-content/uploads/2020/12/britney-1-450x270.jpg 450w" sizes="(max-width: 300px) 100vw, 300px"> <img width=80 height=80 src=http://www.d1softballnews.com/wp-content/uploads/2020/12/britney-1-80x80.jpg class="mob-img wp-post-image" alt loading=lazy srcset="http://www.d1softballnews.com/wp-content/uploads/2020/12/britney-1-80x80.jpg 80w, http://www.d1softballnews.com/wp-content/uploads/2020/12/britney-1-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px"> </a></div><div class="mvp-related-text left relative"> <a href=http://www.d1softballnews.com/britney-spears-and-backstreet-boys-duet-for-the-first-time-in-new-single-matches/>BRITNEY SPEARS AND BACKSTREET BOYS DUET FOR THE FIRST TIME IN NEW SINGLE &#8220;MATCHES&#8221;</a></div> </li></ul></div></div></div></div></div></article><nav class="navigation post-navigation" role=navigation aria-label=Posts><h2 class="screen-reader-text">Post navigation</h2><div class=nav-links><div class=nav-previous><a href=http://www.d1softballnews.com/this-sighting-of-rita-ora-and-taika-waititi-just-seems-to-confirm-that-they-are-a-couple/ rel=prev>THIS SIGHTING OF RITA ORA AND TAIKA WAITITI JUST SEEMS TO CONFIRM THAT THEY ARE A COUPLE</a></div><div class=nav-next><a href=http://www.d1softballnews.com/kanye-west-leaks-details-of-her-failed-marriage-to-kim-kardashian/ rel=next>Kanye West leaks details of her failed marriage to Kim Kardashian</a></div></div></nav></div></div><div id=post-right-col class=relative><div class="side-title-wrap left relative"><h3 class="side-list-title">Most Popular</h3></div><div class="side-pop-wrap left relative"><div class="feat-widget-cont left relative"><div class="feat-widget-wrap left relative"> <a href=http://www.d1softballnews.com/russian-kim-kardashian-anastasia-kvitko-emerges-its-charms/><div class="feat-widget-img left relative"> <img width=300 height=180 src=http://www.d1softballnews.com/wp-content/uploads/2021/04/anastasia-300x180.jpg class="reg-img wp-post-image" alt loading=lazy srcset="http://www.d1softballnews.com/wp-content/uploads/2021/04/anastasia-300x180.jpg 300w, http://www.d1softballnews.com/wp-content/uploads/2021/04/anastasia-1000x600.jpg 1000w, http://www.d1softballnews.com/wp-content/uploads/2021/04/anastasia-450x270.jpg 450w" sizes="(max-width: 300px) 100vw, 300px"> <img width=80 height=80 src=http://www.d1softballnews.com/wp-content/uploads/2021/04/anastasia-80x80.jpg class="mob-img wp-post-image" alt loading=lazy srcset="http://www.d1softballnews.com/wp-content/uploads/2021/04/anastasia-80x80.jpg 80w, http://www.d1softballnews.com/wp-content/uploads/2021/04/anastasia-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px"><div class=feat-info-wrap><div class=feat-info-views> <i class="fa fa-eye fa-2"></i> <span class=feat-info-text>380</span></div></div></div><div class=feat-widget-text> <span class=side-list-cat>CELEBRITIES</span><h2>Russian Kim Kardashian Anastasia Kvitko emerges its charms</h2></div> </a></div><div class="feat-widget-wrap left relative"> <a href=http://www.d1softballnews.com/justin-bieber-hailey-baldwin-dares-the-total-pink-look-and-ignites-the-web/><div class="feat-widget-img left relative"> <img width=300 height=180 src=http://www.d1softballnews.com/wp-content/uploads/2021/04/justin-5-300x180.jpg class="reg-img wp-post-image" alt loading=lazy srcset="http://www.d1softballnews.com/wp-content/uploads/2021/04/justin-5-300x180.jpg 300w, http://www.d1softballnews.com/wp-content/uploads/2021/04/justin-5-1000x600.jpg 1000w, http://www.d1softballnews.com/wp-content/uploads/2021/04/justin-5-450x270.jpg 450w" sizes="(max-width: 300px) 100vw, 300px"> <img width=80 height=80 src=http://www.d1softballnews.com/wp-content/uploads/2021/04/justin-5-80x80.jpg class="mob-img wp-post-image" alt loading=lazy srcset="http://www.d1softballnews.com/wp-content/uploads/2021/04/justin-5-80x80.jpg 80w, http://www.d1softballnews.com/wp-content/uploads/2021/04/justin-5-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px"><div class=feat-info-wrap><div class=feat-info-views> <i class="fa fa-eye fa-2"></i> <span class=feat-info-text>347</span></div></div></div><div class=feat-widget-text> <span class=side-list-cat>CELEBRITIES</span><h2>Justin Bieber: Hailey Baldwin dares the total pink look and ignites the Web!</h2></div> </a></div><div class="feat-widget-wrap left relative"> <a href=http://www.d1softballnews.com/from-miami-lana-rhoades-models-her-best-ensemble/><div class="feat-widget-img left relative"> <img width=300 height=180 src=http://www.d1softballnews.com/wp-content/uploads/2021/04/lana-11-300x180.jpg class="reg-img wp-post-image" alt loading=lazy srcset="http://www.d1softballnews.com/wp-content/uploads/2021/04/lana-11-300x180.jpg 300w, http://www.d1softballnews.com/wp-content/uploads/2021/04/lana-11-1000x600.jpg 1000w, http://www.d1softballnews.com/wp-content/uploads/2021/04/lana-11-450x270.jpg 450w" sizes="(max-width: 300px) 100vw, 300px"> <img width=80 height=80 src=http://www.d1softballnews.com/wp-content/uploads/2021/04/lana-11-80x80.jpg class="mob-img wp-post-image" alt loading=lazy srcset="http://www.d1softballnews.com/wp-content/uploads/2021/04/lana-11-80x80.jpg 80w, http://www.d1softballnews.com/wp-content/uploads/2021/04/lana-11-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px"><div class=feat-info-wrap><div class=feat-info-views> <i class="fa fa-eye fa-2"></i> <span class=feat-info-text>306</span></div></div></div><div class=feat-widget-text> <span class=side-list-cat>CELEBRITIES</span><h2>From Miami, Lana Rhoades models her best ensemble</h2></div> </a></div><div class="feat-widget-wrap left relative"> <a href=http://www.d1softballnews.com/dressed-in-mia-khalifa-flowers-she-sings-to-her-followers/><div class="feat-widget-img left relative"> <img width=300 height=180 src=http://www.d1softballnews.com/wp-content/uploads/2021/04/mia-5-300x180.jpg class="reg-img wp-post-image" alt loading=lazy srcset="http://www.d1softballnews.com/wp-content/uploads/2021/04/mia-5-300x180.jpg 300w, http://www.d1softballnews.com/wp-content/uploads/2021/04/mia-5-1000x600.jpg 1000w, http://www.d1softballnews.com/wp-content/uploads/2021/04/mia-5-450x270.jpg 450w" sizes="(max-width: 300px) 100vw, 300px"> <img width=80 height=80 src=http://www.d1softballnews.com/wp-content/uploads/2021/04/mia-5-80x80.jpg class="mob-img wp-post-image" alt loading=lazy srcset="http://www.d1softballnews.com/wp-content/uploads/2021/04/mia-5-80x80.jpg 80w, http://www.d1softballnews.com/wp-content/uploads/2021/04/mia-5-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px"><div class=feat-info-wrap><div class=feat-info-views> <i class="fa fa-eye fa-2"></i> <span class=feat-info-text>273</span></div></div></div><div class=feat-widget-text> <span class=side-list-cat>CELEBRITIES</span><h2>Dressed in Mia Khalifa flowers, she sings to her followers</h2></div> </a></div><div class="feat-widget-wrap left relative"> <a href=http://www.d1softballnews.com/meghan-markle-harry-cant-wait-to-leave-london-to-find-her/><div class="feat-widget-img left relative"> <img width=300 height=180 src=http://www.d1softballnews.com/wp-content/uploads/2021/04/meghan-3-300x180.jpg class="reg-img wp-post-image" alt loading=lazy srcset="http://www.d1softballnews.com/wp-content/uploads/2021/04/meghan-3-300x180.jpg 300w, http://www.d1softballnews.com/wp-content/uploads/2021/04/meghan-3-1000x600.jpg 1000w, http://www.d1softballnews.com/wp-content/uploads/2021/04/meghan-3-450x270.jpg 450w" sizes="(max-width: 300px) 100vw, 300px"> <img width=80 height=80 src=http://www.d1softballnews.com/wp-content/uploads/2021/04/meghan-3-80x80.jpg class="mob-img wp-post-image" alt loading=lazy srcset="http://www.d1softballnews.com/wp-content/uploads/2021/04/meghan-3-80x80.jpg 80w, http://www.d1softballnews.com/wp-content/uploads/2021/04/meghan-3-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px"><div class=feat-info-wrap><div class=feat-info-views> <i class="fa fa-eye fa-2"></i> <span class=feat-info-text>255</span></div></div></div><div class=feat-widget-text> <span class=side-list-cat>CELEBRITIES</span><h2>Meghan Markle: Harry can&#8217;t wait to leave London to find her!</h2></div> </a></div><div class="feat-widget-wrap left relative"> <a href=http://www.d1softballnews.com/elegant-at-night-demi-rose-picks-up-her-place-as-the-favorite/><div class="feat-widget-img left relative"> <img width=300 height=180 src=http://www.d1softballnews.com/wp-content/uploads/2021/04/demi-11-300x180.jpg class="reg-img wp-post-image" alt loading=lazy srcset="http://www.d1softballnews.com/wp-content/uploads/2021/04/demi-11-300x180.jpg 300w, http://www.d1softballnews.com/wp-content/uploads/2021/04/demi-11-1000x600.jpg 1000w, http://www.d1softballnews.com/wp-content/uploads/2021/04/demi-11-450x270.jpg 450w" sizes="(max-width: 300px) 100vw, 300px"> <img width=80 height=80 src=http://www.d1softballnews.com/wp-content/uploads/2021/04/demi-11-80x80.jpg class="mob-img wp-post-image" alt loading=lazy srcset="http://www.d1softballnews.com/wp-content/uploads/2021/04/demi-11-80x80.jpg 80w, http://www.d1softballnews.com/wp-content/uploads/2021/04/demi-11-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px"><div class=feat-info-wrap><div class=feat-info-views> <i class="fa fa-eye fa-2"></i> <span class=feat-info-text>242</span></div></div></div><div class=feat-widget-text> <span class=side-list-cat>CELEBRITIES</span><h2>Elegant at night, Demi Rose picks up her place as the favorite</h2></div> </a></div><div class="feat-widget-wrap left relative"> <a href=http://www.d1softballnews.com/in-striped-swimsuit-lana-rhoades-melts-everyones-gaze/><div class="feat-widget-img left relative"> <img width=300 height=180 src=http://www.d1softballnews.com/wp-content/uploads/2021/04/lana-9-300x180.jpg class="reg-img wp-post-image" alt loading=lazy srcset="http://www.d1softballnews.com/wp-content/uploads/2021/04/lana-9-300x180.jpg 300w, http://www.d1softballnews.com/wp-content/uploads/2021/04/lana-9-1000x600.jpg 1000w, http://www.d1softballnews.com/wp-content/uploads/2021/04/lana-9-450x270.jpg 450w" sizes="(max-width: 300px) 100vw, 300px"> <img width=80 height=80 src=http://www.d1softballnews.com/wp-content/uploads/2021/04/lana-9-80x80.jpg class="mob-img wp-post-image" alt loading=lazy srcset="http://www.d1softballnews.com/wp-content/uploads/2021/04/lana-9-80x80.jpg 80w, http://www.d1softballnews.com/wp-content/uploads/2021/04/lana-9-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px"><div class=feat-info-wrap><div class=feat-info-views> <i class="fa fa-eye fa-2"></i> <span class=feat-info-text>222</span></div></div></div><div class=feat-widget-text> <span class=side-list-cat>CELEBRITIES</span><h2>In striped swimsuit, Lana Rhoades melts everyone&#8217;s gaze</h2></div> </a></div><div class="feat-widget-wrap left relative"> <a href=http://www.d1softballnews.com/delicious-sweet-mia-khalifa-wears-red-swimsuit-for-session/><div class="feat-widget-img left relative"> <img width=300 height=180 src=http://www.d1softballnews.com/wp-content/uploads/2021/04/mia-8-300x180.jpg class="reg-img wp-post-image" alt loading=lazy srcset="http://www.d1softballnews.com/wp-content/uploads/2021/04/mia-8-300x180.jpg 300w, http://www.d1softballnews.com/wp-content/uploads/2021/04/mia-8-1000x600.jpg 1000w, http://www.d1softballnews.com/wp-content/uploads/2021/04/mia-8-450x270.jpg 450w" sizes="(max-width: 300px) 100vw, 300px"> <img width=80 height=80 src=http://www.d1softballnews.com/wp-content/uploads/2021/04/mia-8-80x80.jpg class="mob-img wp-post-image" alt loading=lazy srcset="http://www.d1softballnews.com/wp-content/uploads/2021/04/mia-8-80x80.jpg 80w, http://www.d1softballnews.com/wp-content/uploads/2021/04/mia-8-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px"><div class=feat-info-wrap><div class=feat-info-views> <i class="fa fa-eye fa-2"></i> <span class=feat-info-text>212</span></div></div></div><div class=feat-widget-text> <span class=side-list-cat>CELEBRITIES</span><h2>Delicious sweet! Mia Khalifa wears red swimsuit for session</h2></div> </a></div><div class="feat-widget-wrap left relative"> <a href=http://www.d1softballnews.com/kim-kardashians-neon-swimsuit-highlights-its-beautiful-curves/><div class="feat-widget-img left relative"> <img width=300 height=180 src=http://www.d1softballnews.com/wp-content/uploads/2021/04/kim-7-300x180.jpg class="reg-img wp-post-image" alt loading=lazy srcset="http://www.d1softballnews.com/wp-content/uploads/2021/04/kim-7-300x180.jpg 300w, http://www.d1softballnews.com/wp-content/uploads/2021/04/kim-7-1000x600.jpg 1000w, http://www.d1softballnews.com/wp-content/uploads/2021/04/kim-7-450x270.jpg 450w" sizes="(max-width: 300px) 100vw, 300px"> <img width=80 height=80 src=http://www.d1softballnews.com/wp-content/uploads/2021/04/kim-7-80x80.jpg class="mob-img wp-post-image" alt loading=lazy srcset="http://www.d1softballnews.com/wp-content/uploads/2021/04/kim-7-80x80.jpg 80w, http://www.d1softballnews.com/wp-content/uploads/2021/04/kim-7-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px"><div class=feat-info-wrap><div class=feat-info-views> <i class="fa fa-eye fa-2"></i> <span class=feat-info-text>194</span></div></div></div><div class=feat-widget-text> <span class=side-list-cat>CELEBRITIES</span><h2>Kim Kardashian&#8217;s neon swimsuit highlights its beautiful curves!</h2></div> </a></div><div class="feat-widget-wrap left relative"> <a href=http://www.d1softballnews.com/the-sun-poses-on-it-kylie-jenner-looks-in-little-fabric/><div class="feat-widget-img left relative"> <img width=300 height=180 src=http://www.d1softballnews.com/wp-content/uploads/2021/04/kylie-6-300x180.jpg class="reg-img wp-post-image" alt loading=lazy srcset="http://www.d1softballnews.com/wp-content/uploads/2021/04/kylie-6-300x180.jpg 300w, http://www.d1softballnews.com/wp-content/uploads/2021/04/kylie-6-1000x600.jpg 1000w, http://www.d1softballnews.com/wp-content/uploads/2021/04/kylie-6-450x270.jpg 450w" sizes="(max-width: 300px) 100vw, 300px"> <img width=80 height=80 src=http://www.d1softballnews.com/wp-content/uploads/2021/04/kylie-6-80x80.jpg class="mob-img wp-post-image" alt loading=lazy srcset="http://www.d1softballnews.com/wp-content/uploads/2021/04/kylie-6-80x80.jpg 80w, http://www.d1softballnews.com/wp-content/uploads/2021/04/kylie-6-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px"><div class=feat-info-wrap><div class=feat-info-views> <i class="fa fa-eye fa-2"></i> <span class=feat-info-text>191</span></div></div></div><div class=feat-widget-text> <span class=side-list-cat>CELEBRITIES</span><h2>The Sun poses on it, Kylie Jenner looks in little fabric</h2></div> </a></div></div></div></div></div></div><div id=foot-ad-wrap class="left relative"><div id=M509325ScriptRootC1027202></div> <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script src=https://jsc.mgid.com/d/1/d1softballnews.com.1027202.js async></script> </div></div></div></div><footer id=foot-wrap class="left relative"><div id=foot-top-wrap class="left relative"><div class="body-main-out relative"><div class=body-main-in><div id=foot-widget-wrap class="left relative"><div class="foot-widget left relative"><div class="foot-logo left realtive"> <img src=http://www.d1softballnews.com/wp-content/uploads/2020/12/d1softfooterlogo.png alt=D1SoftballNews.com data-rjs=2></div><div class="foot-info-text left relative"> D1SoftBallNews.com is one of the most important independent realities active in the panorama of digital media. Every day it makes available to its reader’s contents updated in real-time and is organized in vertical thematic channels.</div><div class="foot-soc left relative"><ul class="foot-soc-list relative"> <li class=foot-soc-twit> <a href=https://twitter.com/D1softballN target=_blank><i class="fa fa-twitter-square fa-2"></i></a> </li> <li class=foot-soc-rss> <a href=http://www.d1softballnews.com/feed/rss/ target=_blank><i class="fa fa-rss-square fa-2"></i></a> </li></ul></div></div></div></div></div></div><div id=foot-bot-wrap class="left relative"><div class="body-main-out relative"><div class=body-main-in><div id=foot-bot class="left relative"><div class="foot-menu relative"><div class=menu-footer-menu-container><ul id=menu-footer-menu class=menu><li id=menu-item-31 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31"><a href=http://www.d1softballnews.com/about-us/>About Us</a></li> <li id=menu-item-30 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-30"><a href=http://www.d1softballnews.com/privacy-policy/>Privacy Policy</a></li> <li id=menu-item-32 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-32"><a href=http://www.d1softballnews.com/contact-us/>Contact Us</a></li> <li id=menu-item-69684 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69684"><a href=http://www.d1softballnews.com/dmca-policy/>DMCA Policy</a></li></ul></div></div><div class="foot-copy relative"><p>Copyright © 2020 D1SoftBall News</p></div></div></div></div></div></footer></div></div></div><div class="fly-to-top back-to-top"> <i class="fa fa-angle-up fa-3"></i> <span class=to-top-text>To Top</span></div><div class=fly-fade></div> <script>jQuery(document).ready(function($){var duration=500;$('.back-to-top').click(function(event){event.preventDefault();$('html, body').animate({scrollTop:0},duration);return false;});$('.menu-item-has-children a').click(function(event){event.stopPropagation();location.href=this.href;});$('.menu-item-has-children').click(function(){$(this).addClass('toggled');if($('.menu-item-has-children').hasClass('toggled'))
{$(this).children('ul').toggle();$('.fly-nav-menu').getNiceScroll().resize();}
$(this).toggleClass('tog-minus');return false;});$(window).load(function(){$('.fly-nav-menu').niceScroll({cursorcolor:"#888",cursorwidth:7,cursorborder:0,zindex:999999});});$(".comment-click-94140").on("click",function(){$(".com-click-id-94140").show();$(".disqus-thread-94140").show();$(".com-but-94140").hide();});$('.infinite-content').infinitescroll({navSelector:".nav-links",nextSelector:".nav-links a:first",itemSelector:".infinite-post",loading:{msgText:"Loading more posts...",finishedMsg:"Sorry, no more posts"},errorCallback:function(){$(".inf-more-but").css("display","none")}});$(window).unbind('.infscr');$(".inf-more-but").click(function(){$('.infinite-content').infinitescroll('retrieve');return false;});$(window).load(function(){if($('.nav-links a').length){$('.inf-more-but').css('display','inline-block');}else{$('.inf-more-but').css('display','none');}});$(window).load(function(){$('.post-gallery-bot').flexslider({animation:"slide",controlNav:false,animationLoop:true,slideshow:false,itemWidth:80,itemMargin:10,asNavFor:'.post-gallery-top'});$('.post-gallery-top').flexslider({animation:"fade",controlNav:false,animationLoop:true,slideshow:false,prevText:"&lt;",nextText:"&gt;",sync:".post-gallery-bot"});});});</script> <script src=http://www.d1softballnews.com/wp-content/cache/minify/74341.js></script> </body></html>